Thumbnail not displaying in Uppy dashboard?

I am a newbie Uppy user. After a little fiddling, I have the Uppy dashboard integrated into my web page, and uploading files with the help of a locally-running tusd server. However, there is one problem that I haven’t been able to figure out: the thumbnails are not displaying, and in the javascript console I am seeing error messages like:

Refused to load the image ‘blob:https:/ /localhost:3010/3c7a66cf-4265-4241-a87b-49f0ec5614f7’ because it violates the following Content Security Policy directive: “img-src ‘self’ data: https:/ /localhost:3010/ https: http:”.

(https:/ /localhost:3010/ is my local web server). The string “blob:https:” looks a little strange, is that what it is supposed to be? I tried prepending the string “blob:” to “https:/ /localhost:3010/” in the place were the content security policy is defined, but the result was the same. I looked around to see if there was a file with that long series of hex groups for a name, but didn’t find it. Can someone give me a short answer for how this is supposed to work or offer an idea for what I might be doing wrong?

Thanks in advance! Uppy looks like a great component so I am hoping to get it working with all its features.


Note: I put a space in between the two slashes in https://localhost because the first time I tried to post I was told that a new user could only have two links… So those are intentional typos.

Solved it! The solution was simply to include “blob:” in the img-src content security policy. I found the answer here: