Method PATCH is not defined in RFC 2068

Hello. I am trying to use tus running in Wildfly 10. For my backend I am using Terri Schwartz’s Java Servlet (tus_servlet). When I run the servlet in jetty (mvn jetty:run), it works perfectly. When I try to run it in our server, Wildfly 10, I get the following error returned to the client: “Method PATCH is not defined in RFC 2068 and is not supported by the Servlet API”.

I’m assuming this is some kind of configuration setting withing Wildfly? Has anyone else encountered this?

Any help greatly appreciated.


Hi Chris, I don’t have any experience with Java Servlets, so I unfortunately cannot help you. I would recommend you to try to contact Terri Schwartz directly at

Thanks for the response. I did figure out what my problem was. I had an incorrect url-pattern in my web.xml.

1 Like

I also want to compliment you on I have a requirement to upload 50gb files. I first tried using flowjs. It only worked in Chrome. IE crashed after 10gb, and Edge after 5gb. I’ve switched to, and it works in all 3, and is about twice as fast. :slight_smile:

Great job!

Thank you very much, Chris! We mostly hear about stuff that does not work, so we are always ecstatic if we hear people enjoy tus :slight_smile: