Is there a file size limit?

Hello, I need to upload very large files (5GB+) to S3.
I was wondering, does Uppy have any caps on how large the file can be?

So it turns out, looks like there is a limit as I just tried uploading a 25 GB file and at the end I received this error message:

expected: 336824,
length: 336824,
limit: 102400,
type: ‘entity.too.large’,
expose: true,
statusCode: 413,
status: 413

This is a bit of a setback and it’s puzzling because 5GB worked fine.
What is the file size limit and is there anyway to get around it?

Files I need to upload are usually in the 25GB to 50GB range.

I used the Uppy.AwsS3Multipart btw.

Hope to hear some answers soon, thanks.

What request showed that error message? I don’t believe we have any explicit size limits anywhere. If something in Uppy or Companion is causing that error, it would be a bug.

I got that message after the file was done uploading, it said Error, so I checked the console and that is what I saw.
I will try another one and paste the entire output.

Somewhat different error now, but I am getting this:

POST http://localhost:3020/s3/multipart/OnZH0aCiroTR5DeF1nzDYu3kgsAom5Xx4izbDKrAJUXc0zOrblrh7VVsizLZ3s3lzAVPJejqa4Us_BAx_2Fu9hGvGQS_wtA5iNYao4GVw9lRVBYnTsotzmlr23PNOK7o/complete?key=test_15gb.dat net::ERR_ABORTED 413 (Payload Too Large)

upload:1 Access to fetch at 'http://localhost:3020/s3/multipart/OnZH0aCiroTR5DeF1nzDYu3kgsAom5Xx4izbDKrAJUXc0zOrblrh7VVsizLZ3s3lzAVPJejqa4Us_BAx_2Fu9hGvGQS_wtA5iNYao4GVw9lRVBYnTsotzmlr23PNOK7o/complete?key=test_15gb.dat' from origin 'http://localhost:3001' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

As you can see, I getting 2 errors:

  1. 413 payload too large
  2. CORS error

I am able to upload small files fine but when uploading large files > 5GB, I get these errors?

You can check this screenshot if it’s helpful: