Getting S3_NOT_FOUND error when uploading/processing assembly

Hello everyone!

I’ve used this assembly in the past without any error and uploaded/transferred to Wasabi many pictures. However, the past 2 months I haven’t worked on the code or needed to upload any pictures. I attempted to upload 5 pictures today and failed with an error of “S3_NOT_FOUND”, HTTP_Code of 404 and ERR.ERROR code of "INTERNAL_COMMAND_ERROR (screenshot below)

The policy for wasabi has worked in the past. A simple policy that allows the S3:PutObject. However, I thought maybe there was an issue with creating a bucket (even thought it has done roughly 100 buckets already), so I modified the policy to include S3:CreateBucket. No luck.

I haven’t changed anything during the time I was not using the upload/transfer, however, I did check that the credentials were correct, the assembly request from my client code was correct, not sure what else to check or show. Any help would be appreciated.

Robert Moore

I’ve found the error. The template (which had not been updated or changed) was pointed to a bucket/directory and Wasabi was not liking that. Once I moved the directory into the path and out of the bucket, it worked just fine.