Getting error "spawn php ENOENT" when run Npm start command for Uppy-aws-presigned-url


#1

Hello guys

@goto-bus-stop
I am getting a weird error (“spawn php ENOENT”) in node.js command prompt when I run Uppy-Aws-presigned-url. I installed “php-cgi” and re-install node_modules but still stuck at same error. Below is the screenshot of the error.
Thanks for the help :slight_smile:


#2

Hi, sorry for the delays—that error happens because it can’t find where PHP is installed. That sort of thing depends a lot on your system so I’m not 100% sure if I can help but I’ll try :slight_smile:

IIRC you mentioned elsewhere that you installed php-cgi. PHP CGI is for use with another web server like Apache, though, it isn’t a standalone executable. You need the PHP CLI instead. On my Linux system that means installing just php, perhaps you can try that?


#3

Hi ,How are you?
Thanks for the reply !! :slightly_smiling_face:

I have a completely window server so now I work with “aws-uppy-server” instead of “aws-presigned-url” and It is almost done but when I put all the key’s in server.js and ran command from node.js then open the browser it’s showing only “Cannot Get/” message on the screen. do you have any idea about it. I attached the screenshot below.
Thanks